From: Michael Opdenacker <michael.opdenacker@free-electrons.com>
To: josh@joshtriplett.org, paul.mckenney@linaro.org,
akpm@linux-foundation.org, decot@googlers.com,
amirv@mellanox.com
Cc: linux-kernel@vger.kernel.org,
Michael Opdenacker <michael.opdenacker@free-electrons.com>
Subject: [RFC][PATCH] genirq: add IRQF_NONE
Date: Mon, 9 Sep 2013 05:48:39 +0200 [thread overview]
Message-ID: <1378698519-4780-1-git-send-email-michael.opdenacker@free-electrons.com> (raw)
What about adding an IRQF_NONE flag as in the below patch?
I'm currently working on removing the use of the deprecated
IRQF_DISABLED flag, and frequently have to replace
IRQF_DISABLED by 0, typically in request_irq() arguments.
Using IRQF_NONE instead of 0 would make the code more readable,
at least for people reading driver code for the first time.
Would it worth it?
I'm sure this kind of idea has come up many times before...
Signed-off-by: Michael Opdenacker <michael.opdenacker@free-electrons.com>
---
include/linux/interrupt.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/linux/interrupt.h b/include/linux/interrupt.h
index 5fa5afe..e289525 100644
--- a/include/linux/interrupt.h
+++ b/include/linux/interrupt.h
@@ -40,6 +40,7 @@
* These flags used only by the kernel as part of the
* irq handling routines.
*
+ * IRQF_NONE - No irq flag bit is set.
* IRQF_DISABLED - keep irqs disabled when calling the action handler.
* DEPRECATED. This flag is a NOOP and scheduled to be removed
* IRQF_SHARED - allow sharing the irq among several devices
@@ -59,6 +60,7 @@
* IRQF_EARLY_RESUME - Resume IRQ early during syscore instead of at device
* resume time.
*/
+#define IRQF_NONE 0x00000000
#define IRQF_DISABLED 0x00000020
#define IRQF_SHARED 0x00000080
#define IRQF_PROBE_SHARED 0x00000100
--
1.8.1.2
next reply other threads:[~2013-09-09 3:48 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-09-09 3:48 Michael Opdenacker [this message]
2013-09-09 4:02 ` Josh Triplett
2013-09-09 4:40 ` Michael Opdenacker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1378698519-4780-1-git-send-email-michael.opdenacker@free-electrons.com \
--to=michael.opdenacker@free-electrons.com \
--cc=akpm@linux-foundation.org \
--cc=amirv@mellanox.com \
--cc=decot@googlers.com \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=paul.mckenney@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®