mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Fenghua Yu" <fenghua.yu@intel.com>
To: "Thomas Gleixner" <tglx@linutronix.de>
Cc: "Ingo Molnar" <mingo@elte.hu>,
	"H. Peter Anvin" <h.peter.anvin@intel.com>,
	"Tony Luck" <tony.luck@intel.com>, "Borislav Petkov" <bp@suse.de>,
	"Stephane Eranian" <eranian@google.com>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Dave Hansen" <dave.hansen@intel.com>,
	"David Carrillo-Cisneros" <davidcc@google.com>,
	"Ravi V Shankar" <ravi.v.shankar@intel.com>,
	"Vikas Shivappa" <vikas.shivappa@linux.intel.com>,
	"Sai Prakhya" <sai.praneeth.prakhya@intel.com>,
	"Nilay Vaish" <nilayvaish@gmail.com>, "Shaohua Li" <shli@fb.com>,
	"linux-kernel" <linux-kernel@vger.kernel.org>,
	"x86" <x86@kernel.org>, "Fenghua Yu" <fenghua.yu@intel.com>
Subject: [PATCH v6 00/10] Intel Cache Allocation Technology
Date: Fri, 28 Oct 2016 15:04:39 -0700	[thread overview]
Message-ID: <1477692289-37412-1-git-send-email-fenghua.yu@intel.com> (raw)

From: Fenghua Yu <fenghua.yu@intel.com>

This version is supposed to cover all comments from Thomas.

Patch 1-4, 6-9 of 18 v5 patches are in tip x86/cache branch. We
have rest of 10 patches in v6 on top of tip tree.

Change log in v6:

patch 1 (i.e. patch 5 in v5): Change max_cbm_val to cbm_mask.

patch 2 (i.e. patch 10 in v5): Change comments for rdt_find_domain and
domain_add_cpu() to explain why domain list is sorted by id. Change
the pos argument to optional in rdt_rind_domain and assign NULL to it
in caller domain_remove_cpu.

patch 3 (i.e. patch 11 in v5): Remove arg's type cast in
l3_qos_cfg_update(). Change the local variable declaration lines in
more readable way. Disable CDP in umount only when it's enabled. Fix
an error handling issue in rdt_mount.

patch 4 (i.e. patch 12 in v5): Change names from "num_closid" to
"num_closids" and from "cbm_val" to "cbm_mask" in res_info_files. Remove
the unused label "out" in rdtgroup_setup_root() and will add it later when
it's used.

patch 5 (i.e. patch 13 in v5): Init closid_free_map by minimal closid
instead of by maximum closid in all resources.

patch 6 (i.e. patch 14 in v5): Change local variable declaration lines
to more readable way.

patch 7 (i.e. patch 15 in v5): Change for_each_process to
for_each_process_thread

patch 8 (i.e. patch 16 in v5): Change local variable declaration lines
to more readable way.

patch 9 (i.e. patch 17 in v5): No change.

patch 10 (i.e. patch 18 in v5): No change.

Fenghua Yu (7):
  Documentation, x86: Documentation for Intel resource allocation user
    interface
  x86/intel_rdt: Add basic resctrl filesystem support
  x86/intel_rdt: Add "info" files to resctrl file system
  x86/intel_rdt: Add mkdir to resctrl file system
  x86/intel_rdt: Add tasks files
  x86/intel_rdt: Add scheduler hook
  MAINTAINERS: Add maintainer for Intel RDT resource allocation

Tony Luck (3):
  x86/intel_rdt: Build structures for each resource based on cache
    topology
  x86/intel_rdt: Add cpus file
  x86/intel_rdt: Add schemata file

 Documentation/x86/intel_rdt_ui.txt       |  167 +++++
 MAINTAINERS                              |    8 +
 arch/x86/include/asm/intel_rdt.h         |  145 +++++
 arch/x86/kernel/cpu/Makefile             |    2 +-
 arch/x86/kernel/cpu/intel_rdt.c          |  213 ++++++-
 arch/x86/kernel/cpu/intel_rdt_rdtgroup.c | 1007 ++++++++++++++++++++++++++++++
 arch/x86/kernel/cpu/intel_rdt_schemata.c |  245 ++++++++
 arch/x86/kernel/process_32.c             |    4 +
 arch/x86/kernel/process_64.c             |    4 +
 include/linux/sched.h                    |    3 +
 include/uapi/linux/magic.h               |    1 +
 11 files changed, 1797 insertions(+), 2 deletions(-)
 create mode 100644 Documentation/x86/intel_rdt_ui.txt
 create mode 100644 arch/x86/kernel/cpu/intel_rdt_rdtgroup.c
 create mode 100644 arch/x86/kernel/cpu/intel_rdt_schemata.c

-- 
2.5.0

             reply	other threads:[~2016-10-28 22:05 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-28 22:04 Fenghua Yu [this message]
2016-10-28 22:04 ` [PATCH v6 01/10] Documentation, x86: Documentation for Intel resource allocation user interface Fenghua Yu
2016-10-31  1:22   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 02/10] x86/intel_rdt: Build structures for each resource based on cache topology Fenghua Yu
2016-10-31  1:22   ` [tip:x86/cache] " tip-bot for Tony Luck
2016-10-28 22:04 ` [PATCH v6 03/10] x86/intel_rdt: Add basic resctrl filesystem support Fenghua Yu
2016-10-31  1:13   ` Thomas Gleixner
2016-10-31  1:23   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 04/10] x86/intel_rdt: Add "info" files to resctrl file system Fenghua Yu
2016-10-31  1:24   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 05/10] x86/intel_rdt: Add mkdir " Fenghua Yu
2016-10-31  1:24   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 06/10] x86/intel_rdt: Add cpus file Fenghua Yu
2016-10-31  1:25   ` [tip:x86/cache] " tip-bot for Tony Luck
2016-10-28 22:04 ` [PATCH v6 07/10] x86/intel_rdt: Add tasks files Fenghua Yu
2016-10-31  1:25   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 08/10] x86/intel_rdt: Add schemata file Fenghua Yu
2016-10-31  1:26   ` [tip:x86/cache] " tip-bot for Tony Luck
2016-10-28 22:04 ` [PATCH v6 09/10] x86/intel_rdt: Add scheduler hook Fenghua Yu
2016-10-31  1:26   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-28 22:04 ` [PATCH v6 10/10] MAINTAINERS: Add maintainer for Intel RDT resource allocation Fenghua Yu
2016-10-31  1:27   ` [tip:x86/cache] " tip-bot for Fenghua Yu
2016-10-31  1:18 ` [PATCH v6 00/10] Intel Cache Allocation Technology Thomas Gleixner
2016-10-31  3:06   ` Yu, Fenghua

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1477692289-37412-1-git-send-email-fenghua.yu@intel.com \
    --to=fenghua.yu@intel.com \
    --cc=bp@suse.de \
    --cc=dave.hansen@intel.com \
    --cc=davidcc@google.com \
    --cc=eranian@google.com \
    --cc=h.peter.anvin@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=nilayvaish@gmail.com \
    --cc=peterz@infradead.org \
    --cc=ravi.v.shankar@intel.com \
    --cc=sai.praneeth.prakhya@intel.com \
    --cc=shli@fb.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=vikas.shivappa@linux.intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®