mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "H. Peter Anvin" <hpa@zytor.com>
To: Andrew Morton <akpm@linux-foundation.org>, Ingo Molnar <mingo@elte.hu>
Cc: Pekka Enberg <penberg@kernel.org>,
	David Rientjes <rientjes@google.com>,
	Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Casey Dahlin <cdahlin@redhat.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org,
	Linus Torvalds <torvalds@linux-foundation.org>
Subject: Re: [patch] x86: allow ZONE_DMA to be configurable
Date: Thu, 14 Oct 2010 13:40:37 -0700	[thread overview]
Message-ID: <1bdcb8fa-d858-4a79-ae28-de8c94d13f5f@email.android.com> (raw)
In-Reply-To: <20101014123511.d628f873.akpm@linux-foundation.org>

I don't like the CONFIG_EXPERT prefix, just because it makes it hard to move things into and out of this rubric, and that's bad... (consider: "oh, that would mean this *huge* patch) ... not to mention that what is CONFIG_EXPERT on one platform may not be for another!  As far as the main switch is concerned, it's a better name of course...

"Andrew Morton" <akpm@linux-foundation.org> wrote:

>On Thu, 14 Oct 2010 20:34:48 +0200
>Ingo Molnar <mingo@elte.hu> wrote:
>
>> 
>> * H. Peter Anvin <hpa@zytor.com> wrote:
>> 
>> > On 10/14/2010 09:00 AM, Pekka Enberg wrote:
>> >
>> > >> CONFIG_EMBEDDED *is* "I am a user who (think I) know what I'm 
>> > >> doing". That is *what it is* and *all it is*.
>> > > 
>> > > Yup. The naming is quite unfortunate, though. Can we change it to 
>> > > something else?
>> > 
>> > Funny, this seems to come up repeatedly ;)
>> 
>> I'd suggest to rename CONFIG_EMBEDDED=y to CONFIG_EXPERT=y, but i'd also 
>> suggest to rename all sub-config-options that depend on CONFIG_EXPERT to 
>> have a CONFIG_EXPERT_ prefix.
>> 
>> So we'd have:
>> 
>>   CONFIG_EXPERT_CPU_SUP_INTEL=y
>>   CONFIG_EXPERT_MMAP_ALLOW_UNINITIALIZED=y
>> 
>> etc.
>
>yup.  CONFIG_EMBEDDED didn't make a lot of sense even when we first did it. 
>I suppose CONFIG_EXPERT is OK, although everyone will select it because
>they think they're experts ;)  CONFIG_PROPELLORHEAD!
>
>> That way all the enabled 'expert options' become easily visible in the 
>> .config file and they advertise themselves properly - it's also easily 
>> greppable. In the source code it also becomes self-documenting, it's 
>> obvious when a dependency is 'rare' or 'special' - it has a 
>> CONFIG_EXPERT_ prefix.
>> 
>> Something for the KS i guess.
>
>nah, just do it.

-- 
Sent from my mobile phone.  Please pardon any lack of formatting.

  reply	other threads:[~2010-10-14 20:42 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-14  0:15 David Rientjes
2010-10-14  0:23 ` H. Peter Anvin
2010-10-14  0:42   ` David Rientjes
2010-10-14  0:44     ` H. Peter Anvin
2010-10-14  0:49       ` David Rientjes
2010-10-14  1:21         ` H. Peter Anvin
2010-10-14  1:48           ` David Rientjes
2010-10-14  2:38             ` H. Peter Anvin
2010-10-14  3:55               ` David Rientjes
2010-10-14  4:37             ` H. Peter Anvin
2010-10-14  4:46               ` David Rientjes
2010-10-14 15:38                 ` H. Peter Anvin
2010-10-14 16:00                   ` Pekka Enberg
2010-10-14 17:44                     ` H. Peter Anvin
2010-10-14 18:34                       ` Ingo Molnar
2010-10-14 19:35                         ` Andrew Morton
2010-10-14 20:40                           ` H. Peter Anvin [this message]
2010-10-15  3:03                             ` Ingo Molnar
2010-10-15  4:45                               ` H. Peter Anvin
2010-10-15  9:05                               ` David Rientjes
2010-10-15 15:06                                 ` H. Peter Anvin
2010-10-14 22:08                   ` David Rientjes
2010-10-14  8:10 ` Andrew Morton
2010-10-14  8:32   ` KOSAKI Motohiro
2010-10-14 22:15   ` David Rientjes
2010-10-14 22:32     ` Andrew Morton
2010-10-15  3:10       ` Ingo Molnar
2010-10-15  9:11         ` David Rientjes
2010-10-15  9:09       ` David Rientjes
2010-10-21 14:56         ` Christoph Lameter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1bdcb8fa-d858-4a79-ae28-de8c94d13f5f@email.android.com \
    --to=hpa@zytor.com \
    --cc=akpm@linux-foundation.org \
    --cc=cdahlin@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=mingo@redhat.com \
    --cc=penberg@kernel.org \
    --cc=rientjes@google.com \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®