From: Ramiro Oliveira <Ramiro.Oliveira@synopsys.com>
To: Pavel Machek <pavel@ucw.cz>,
Ramiro Oliveira <Ramiro.Oliveira@synopsys.com>
Cc: <linux-kernel@vger.kernel.org>, <linux-media@vger.kernel.org>,
<devicetree@vger.kernel.org>, <robh+dt@kernel.org>,
<mark.rutland@arm.com>, <mchehab@kernel.org>,
<davem@davemloft.net>, <geert@linux-m68k.org>,
<akpm@linux-foundation.org>, <kvalo@codeaurora.org>,
<linux@roeck-us.net>, <hverkuil@xs4all.nl>, <lars@metafoo.de>,
<robert.jarzmik@free.fr>, <slongerbeam@gmail.com>,
<dheitmueller@kernellabs.com>, <pali.rohar@gmail.com>,
<CARLOS.PALMINHA@synopsys.com>
Subject: Re: [PATCH v3 2/2] Add support for Omnivision OV5647
Date: Wed, 19 Oct 2016 12:12:00 +0100 [thread overview]
Message-ID: <375952b7-7993-b23a-10e8-85cba64b2679@synopsys.com> (raw)
In-Reply-To: <20161018183133.GA26548@amd>
Hi!
On 10/18/2016 7:31 PM, Pavel Machek wrote:
> Hi!
>
>> +/*
>> + * A V4L2 driver for OmniVision OV5647 cameras.
>> + *
>> + * Based on Samsung S5K6AAFX SXGA 1/6" 1.3M CMOS Image Sensor driver
>> + * Copyright (C) 2011 Sylwester Nawrocki <s.nawrocki@samsung.com>
>> + *
>> + * Based on Omnivision OV7670 Camera Driver
>> + * Copyright (C) 2006-7 Jonathan Corbet <corbet@lwn.net>
>> + *
>> + * Copyright (C) 2016, Synopsys, Inc.
>> + *
>> + */
> If you do copyrights, you should also specify license.
>
>> +static bool debug;
>> +module_param(debug, bool, 0644);
>> +MODULE_PARM_DESC(debug, "Debug level (0-1)");
> Please remove, we have generic infrastructure for debugging.
>
>> +/*
>> + * The ov5647 sits on i2c with ID 0x6c
>> + */
>> +#define OV5647_I2C_ADDR 0x6c
>> +#define SENSOR_NAME "ov5647"
>> +
>> +#define OV5647_REG_CHIPID_H 0x300A
>> +#define OV5647_REG_CHIPID_L 0x300B
>> +
>> +#define REG_TERM 0xfffe
>> +#define VAL_TERM 0xfe
>> +#define REG_DLY 0xffff
>> +
>> +/*define the voltage level of control signal*/
> "/* ", " */".
>
>> +#define CSI_STBY_ON 1
>> +#define CSI_STBY_OFF 0
>> +#define CSI_RST_ON 0
>> +#define CSI_RST_OFF 1
>> +#define CSI_PWR_ON 1
>> +#define CSI_PWR_OFF 0
>> +#define CSI_AF_PWR_ON 1
>> +#define CSI_AF_PWR_OFF 0
> ...
>> +enum power_seq_cmd {
>> + CSI_SUBDEV_PWR_OFF = 0x00,
>> + CSI_SUBDEV_PWR_ON = 0x01,
>> +};
> Pick one style for defines/enums?
>
>> +struct regval_list {
>> + uint16_t addr;
>> + uint8_t data;
>> +};
> u8/u16?
This sensor uses 16 bits for addresses and 8 for data, so I think it makes sense
to keep it this way.
>
>> +/**
>> +* @short I2C Write operation
>> +* @param[in] i2c_client I2C client
>> +* @param[in] reg register address
>> +* @param[in] val value to write
>> +* @return Error code
>> +*/
> " *"?
>
>> +static int ov5647_write(struct v4l2_subdev *sd, uint16_t reg, uint8_t val)
>> +{
>> + int ret;
>> + unsigned char data[3] = { reg >> 8, reg & 0xff, val};
> " }".
>
>> +static int ov5647_write_array(struct v4l2_subdev *subdev,
>> + struct regval_list *regs, int array_size)
>> +{
>> + int i = 0;
>> + int ret = 0;
>> +
>> + if (!regs)
>> + return -EINVAL;
>> +
>> + while (i < array_size) {
>> + if (regs->addr == REG_DLY)
>> + mdelay(regs->data);
>> + else
>> + ret = ov5647_write(subdev, regs->addr, regs->data);
> The "REG_DLY" is never used AFAICT? Remove?
>
>> + if (ret == -EIO)
>> + return ret;
>> +
> ov5647_write() can return errors other then EIO. Are they handled correctly?
>
>> +/**
>> + * @short Set SW standby
>> + * @param[in] subdev v4l2 subdev
>> + * @param[in] on_off standby on or off
>> + * @return Error code
>> + */
>> +static int sensor_s_sw_stby(struct v4l2_subdev *subdev, int on_off)
>> +{
>> + int ret;
>> + unsigned char rdval;
>> +
>> + ret = ov5647_read(subdev, 0x0100, &rdval);
>> + if (ret != 0)
>> + return ret;
>> +
>> + if (on_off == CSI_STBY_ON)
>> + ret = ov5647_write(subdev, 0x0100, rdval&0xfe);
>> +
>> + else
>> + ret = ov5647_write(subdev, 0x0100, rdval|0x01);
> I'd get rid of CSI_STBY_ON, and convert arg to bool, as you don't
> really handle other values. Plus, naming it "set_sw_standby()" would
> make core slightly more readable. Also kill the empty line before
> else.
>
>> +/**
>> +* @short Initialize sensor
>> +* @param[in] subdev v4l2 subdev
>> +* @param[in] val not used
>> +* @return Error code
>> +*/
>> +static int __sensor_init(struct v4l2_subdev *subdev)
>> +{
>> + int ret;
>> + uint8_t resetval;
>> + unsigned char rdval;
> u8 for both?
>
>> + ov5647_read(subdev, 0x0100, &resetval);
>> + if (!resetval&0x01) {
>> + v4l2_dbg(1, debug, subdev,
>> + "DEVICE WAS IN SOFTWARE STANDBY");
> No shouting please? If it is important maybe it should have higher
> priority?
>
>> +static int sensor_power(struct v4l2_subdev *subdev, int on)
>> +{
>> + int ret;
>> + struct ov5647 *ov5647 = to_state(subdev);
>> +
>> + ret = 0;
>> + mutex_lock(&ov5647->lock);
>> +
>> + switch (on) {
>> + case CSI_SUBDEV_PWR_OFF:
> ...
>> + case CSI_SUBDEV_PWR_ON:
> ...
>> + default:
>> + return -EINVAL;
>> + }
>> +
>> + mutex_unlock(&ov5647->lock);
> I'd really convert this to bool. Note how it returns with lock held?
>
>
>> +int ov5647_detect(struct v4l2_subdev *sd)
>> +{
>> + unsigned char v;
>> + int ret;
>> +
>> + ret = sensor_power(sd, 1);
>> + if (ret < 0)
>> + return ret;
>> + ret = ov5647_read(sd, OV5647_REG_CHIPID_H, &v);
>> + if (ret < 0)
>> + return ret;
>> + if (v != 0x56) /* OV manuf. id. */
>> + return -ENODEV;
>> + ret = ov5647_read(sd, OV5647_REG_CHIPID_L, &v);
>> + if (ret < 0)
>> + return ret;
>> + if (v != 0x47)
>> + return -ENODEV;
> I guess invalid chipid deserves a printk?
>
>> +* Refer to Linux errors.
> Useful?
>
>> +/**
>> +* @short of_device_id structure
>> +*/
>> +static const struct i2c_device_id ov5647_id[] = {
> Umm. The comment looks useless and wrong.
>
> Best regards,
> Pavel
Thanks for the feedback. I agree with most of your suggestions, and I commented
with the one I didn't agree.
Thanks,
Ramiro
next prev parent reply other threads:[~2016-10-19 14:50 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-10-12 16:02 [PATCH v3 0/2] OV5647 Sensor driver Ramiro Oliveira
2016-10-12 16:02 ` [PATCH v3 1/2] Add OV5647 device tree documentation Ramiro Oliveira
2016-10-18 13:14 ` Rob Herring
2016-10-18 13:38 ` Ramiro Oliveira
2016-10-12 16:02 ` [PATCH v3 2/2] Add support for Omnivision OV5647 Ramiro Oliveira
2016-10-18 18:31 ` Pavel Machek
2016-10-19 11:12 ` Ramiro Oliveira [this message]
2016-10-19 11:15 ` Pavel Machek
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=375952b7-7993-b23a-10e8-85cba64b2679@synopsys.com \
--to=ramiro.oliveira@synopsys.com \
--cc=CARLOS.PALMINHA@synopsys.com \
--cc=akpm@linux-foundation.org \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=dheitmueller@kernellabs.com \
--cc=geert@linux-m68k.org \
--cc=hverkuil@xs4all.nl \
--cc=kvalo@codeaurora.org \
--cc=lars@metafoo.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mark.rutland@arm.com \
--cc=mchehab@kernel.org \
--cc=pali.rohar@gmail.com \
--cc=pavel@ucw.cz \
--cc=robert.jarzmik@free.fr \
--cc=robh+dt@kernel.org \
--cc=slongerbeam@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®