From: Paolo Bonzini <pbonzini@redhat.com>
To: Vitaly Kuznetsov <vkuznets@redhat.com>,
Sean Christopherson <sean.j.christopherson@intel.com>
Cc: kvm@vger.kernel.org, "Radim Krčmář" <rkrcmar@redhat.com>,
x86@kernel.org, "Andy Lutomirski" <luto@kernel.org>,
"Dmitry V . Levin" <ldv@altlinux.org>,
"Masatake YAMATO" <yamato@redhat.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] x86/kvm/vmx: don't read current->thread.{fs,gs}base of legacy tasks
Date: Sun, 15 Jul 2018 16:27:01 +0200 [thread overview]
Message-ID: <7a455c76-50c5-814a-0a75-c3a8b3ce4eeb@redhat.com> (raw)
In-Reply-To: <87lgafvz6p.fsf@vitty.brq.redhat.com>
On 13/07/2018 19:10, Vitaly Kuznetsov wrote:
>> Because bikeshedding is fun, what do you think about using fs_base and
>> kernel_gs_base for these names? I have a series that touches this
>> code and also adds local variables for {FS,GS}.base and {FS,GS}.sel.
>> I used {fs,gs}_base and {fs,gs}_sel to be consistent with the
>> vmx->host_state nomenclature (the local variables are used to update
>> the associated vmx->host_state variables), but I'll change my patches
>> if you have a strong preference for omitting the underscore.
>>
> I have nothing against underscores :-)
>
> Hope this small change can be done by Paolo/Radim upon commit. Or I'll
> send v2 if needed.
Yup, I've made the change and queued for 4.18-rc.
Paolo
prev parent reply other threads:[~2018-07-15 14:27 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-11 17:37 Vitaly Kuznetsov
2018-07-12 1:39 ` Wanpeng Li
2018-07-12 9:31 ` Vitaly Kuznetsov
2018-07-12 11:23 ` Vitaly Kuznetsov
2018-07-13 16:46 ` Sean Christopherson
2018-07-13 17:10 ` Vitaly Kuznetsov
2018-07-15 14:27 ` Paolo Bonzini [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7a455c76-50c5-814a-0a75-c3a8b3ce4eeb@redhat.com \
--to=pbonzini@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=ldv@altlinux.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@kernel.org \
--cc=rkrcmar@redhat.com \
--cc=sean.j.christopherson@intel.com \
--cc=vkuznets@redhat.com \
--cc=x86@kernel.org \
--cc=yamato@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®