From: bot+bpf-ci@kernel.org
To: git@danielhodges.dev,bpf@vger.kernel.org,linux-crypto@vger.kernel.org,linux-kernel@vger.kernel.org,linux-kselftest@vger.kernel.org
Cc: ast@kernel.org,andrii@kernel.org,daniel@iogearbox.net,vadim.fedorenko@linux.dev,song@kernel.org,yatsenko@meta.com,martin.lau@linux.dev,eddyz87@gmail.com,haoluo@google.com,jolsa@kernel.org,john.fastabend@gmail.com,kpsingh@kernel.org,sdf@fomichev.me,yonghong.song@linux.dev,herbert@gondor.apana.org.au,davem@davemloft.net,git@danielhodges.dev,ast@kernel.org,andrii@kernel.org,daniel@iogearbox.net,martin.lau@kernel.org,eddyz87@gmail.com,yonghong.song@linux.dev,clm@meta.com,ihor.solodrai@linux.dev
Subject: Re: [PATCH bpf-next v8 3/4] bpf: Add signature verification kfuncs
Date: Wed, 25 Feb 2026 21:06:35 +0000 (UTC) [thread overview]
Message-ID: <8764e69fa3f63a498f9e0008f6936efdeeb0d17546b31b416f22da7ffdb40cac@mail.kernel.org> (raw)
In-Reply-To: <20260225202935.31986-4-git@danielhodges.dev>
[-- Attachment #1: Type: text/plain, Size: 2189 bytes --]
> Add enum bpf_crypto_type_id for runtime type checking to ensure
> operations are performed on the correct crypto context type. The enum
> values are assigned to all crypto type modules (skcipher, hash, sig).
This paragraph appears to be inaccurate. The enum bpf_crypto_type_id and
all three values (BPF_CRYPTO_TYPE_SKCIPHER, BPF_CRYPTO_TYPE_HASH,
BPF_CRYPTO_TYPE_SIG) were added in the earlier commit ddee9f01e40e
("bpf: Add hash kfunc for cryptographic hashing"), along with the
type_id field in struct bpf_crypto_type and the assignment to the
skcipher module.
Should this paragraph be removed or reworded to reflect what this
commit actually introduces?
> diff --git a/kernel/bpf/crypto.c b/kernel/bpf/crypto.c
> --- a/kernel/bpf/crypto.c
> +++ b/kernel/bpf/crypto.c
[ ... ]
> @@ -438,6 +549,12 @@ __bpf_kfunc int bpf_sig_maxsize(struct bpf_crypto_ctx *ctx)
> #if IS_ENABLED(CONFIG_CRYPTO_HASH2)
> BTF_ID_FLAGS(func, bpf_crypto_hash, KF_RCU)
> #endif
> +#if IS_ENABLED(CONFIG_CRYPTO_SIG2)
> +BTF_ID_FLAGS(func, bpf_sig_verify, KF_RCU)
> +BTF_ID_FLAGS(func, bpf_sig_keysize)
> +BTF_ID_FLAGS(func, bpf_sig_digestsize)
> +BTF_ID_FLAGS(func, bpf_sig_maxsize)
> +#endif
This isn't a bug, but the existing kfuncs in this file follow the
bpf_crypto_ naming convention: bpf_crypto_encrypt, bpf_crypto_decrypt,
bpf_crypto_hash. The new kfuncs use bpf_sig_ instead. Would
bpf_crypto_sig_verify (and similar) be more consistent for API
discoverability?
---
AI reviewed your patch. Please fix the bug or email reply why it's not a bug.
See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md
CI run summary: https://github.com/kernel-patches/bpf/actions/runs/22414975518
AI-authorship-score: medium
AI-authorship-explanation: Formulaic boilerplate code and polished commit message suggest possible AI assistance, but iterative v1-v8 development with lore interaction and a human-like commit message inaccuracy pattern indicate primarily human authorship.
issues-found: 2
issue-severity-score: low
issue-severity-explanation: Commit message inaccuracy about enum addition and kfunc naming inconsistency are documentation and style issues with no runtime impact.
next prev parent reply other threads:[~2026-02-25 21:06 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-25 20:29 [PATCH bpf-next v8 0/4] Add cryptographic hash and signature verification kfuncs to BPF Daniel Hodges
2026-02-25 20:29 ` [PATCH bpf-next v8 1/4] bpf: Add hash kfunc for cryptographic hashing Daniel Hodges
2026-02-25 21:06 ` bot+bpf-ci
2026-02-25 20:29 ` [PATCH bpf-next v8 2/4] selftests/bpf: Add tests for bpf_crypto_hash kfunc Daniel Hodges
2026-02-25 20:29 ` [PATCH bpf-next v8 3/4] bpf: Add signature verification kfuncs Daniel Hodges
2026-02-25 21:06 ` bot+bpf-ci [this message]
2026-02-25 20:29 ` [PATCH bpf-next v8 4/4] selftests/bpf: Add tests for " Daniel Hodges
2026-05-21 16:30 ` [PATCH bpf-next v8 0/4] Add cryptographic hash and signature verification kfuncs to BPF Felix Maurer
2026-05-22 10:57 ` Daniel Hodges
2026-06-10 19:17 ` Felix Maurer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8764e69fa3f63a498f9e0008f6936efdeeb0d17546b31b416f22da7ffdb40cac@mail.kernel.org \
--to=bot+bpf-ci@kernel.org \
--cc=andrii@kernel.org \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=clm@meta.com \
--cc=daniel@iogearbox.net \
--cc=davem@davemloft.net \
--cc=eddyz87@gmail.com \
--cc=git@danielhodges.dev \
--cc=haoluo@google.com \
--cc=herbert@gondor.apana.org.au \
--cc=ihor.solodrai@linux.dev \
--cc=john.fastabend@gmail.com \
--cc=jolsa@kernel.org \
--cc=kpsingh@kernel.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=martin.lau@kernel.org \
--cc=martin.lau@linux.dev \
--cc=sdf@fomichev.me \
--cc=song@kernel.org \
--cc=vadim.fedorenko@linux.dev \
--cc=yatsenko@meta.com \
--cc=yonghong.song@linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®