mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Zi Yan" <ziy@nvidia.com>
To: "David Hildenbrand (Arm)" <david@kernel.org>,
	"Andrew Morton" <akpm@linux-foundation.org>,
	"Lorenzo Stoakes" <ljs@kernel.org>,
	"Liam R. Howlett" <liam@infradead.org>,
	"Vlastimil Babka" <vbabka@kernel.org>,
	"Mike Rapoport" <rppt@kernel.org>,
	"Suren Baghdasaryan" <surenb@google.com>,
	"Michal Hocko" <mhocko@suse.com>,
	"Kairui Song" <kasong@tencent.com>,
	"Qi Zheng" <qi.zheng@linux.dev>,
	"Shakeel Butt" <shakeel.butt@linux.dev>,
	"Barry Song" <baohua@kernel.org>,
	"Axel Rasmussen" <axelrasmussen@google.com>,
	"Yuanchu Xie" <yuanchu@google.com>, "Wei Xu" <weixugc@google.com>,
	"Baoquan He" <baoquan.he@linux.dev>,
	"Baolin Wang" <baolin.wang@linux.alibaba.com>,
	"Brendan Jackman" <brendan.jackman@linux.dev>,
	"Johannes Weiner" <hannes@cmpxchg.org>,
	"Jan Kiszka" <jan.kiszka@siemens.com>,
	"Kieran Bingham" <kbingham@kernel.org>,
	"Oscar Salvador" <osalvador@suse.de>,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	"Danilo Krummrich" <dakr@kernel.org>
Cc: <linux-kernel@vger.kernel.org>, <linux-mm@kvack.org>,
	<linux-cxl@vger.kernel.org>, <driver-core@lists.linux.dev>,
	<linux-fsdevel@vger.kernel.org>
Subject: Re: [PATCH v2 01/13] mm/sparse: move mem_section init to sparse_extreme_init()
Date: Mon, 21 Sep 2026 19:12:17 -0400	[thread overview]
Message-ID: <DLLDI7J2Z7L3.142FJJM03D1IV@nvidia.com> (raw)
In-Reply-To: <20260921-b4-sparsemem_cleanups-v2-1-54d81d65e125@kernel.org>

On Mon Sep 21, 2026 at 3:58 PM EDT, David Hildenbrand (Arm) wrote:
> Let's just avoid another pair of ifdef inside a function. While at it,
> switch to INTERNODE_CACHE_BYTES by just defining a fallback in cache.h
> as well, given that the x86 variant already provides one.
>
> Acked-by: Oscar Salvador <osalvador@suse.de>
> Reviewed-by: Lorenzo Stoakes (ARM) <ljs@kernel.org>
> Reviewed-by: Mike Rapoport (Microsoft) <rppt@kernel.org>
> Signed-off-by: David Hildenbrand (Arm) <david@kernel.org>
> ---
>  include/linux/cache.h |  1 +
>  mm/sparse.c           | 19 ++++++++++++-------
>  2 files changed, 13 insertions(+), 7 deletions(-)
>
LGTM.

Reviewed-by: Zi Yan <ziy@nvidia.com>

-- 
Best Regards,
Yan, Zi


  reply	other threads:[~2026-09-21 23:12 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-21 19:58 [PATCH v2 00/13] mm/sparse: remove SECTION_MARKED_PRESENT and further cleanups David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 01/13] mm/sparse: move mem_section init to sparse_extreme_init() David Hildenbrand (Arm)
2026-09-21 23:12   ` Zi Yan [this message]
2026-09-21 19:58 ` [PATCH v2 02/13] mm/sparse: refactor sparse_sections_init() David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 03/13] mm/sparse: move initialization of section metadata to sparse_metadata_init() David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 04/13] mm/sparse: rename and cleanup sparse_init_nid() David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 05/13] mm/sparse: cleanup sparse_init_one_section() David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 06/13] mm/sparse: rename __highest_present_section_nr to __highest_used_section_nr David Hildenbrand (Arm)
2026-09-21 19:58 ` [PATCH v2 07/13] mm/sparse: remove pfn_in_present_section() David Hildenbrand (Arm)
2026-09-21 19:59 ` [PATCH v2 08/13] mm/sparse: move __highest_used_section_nr handling David Hildenbrand (Arm)
2026-09-22  4:24   ` Oscar Salvador (SUSE)
2026-09-22 10:22     ` David Hildenbrand (Arm)
2026-09-21 19:59 ` [PATCH v2 09/13] scripts/gdb: mm.py: remove fallbacks for SECTION_HAS_MEM_MAP and SECTION_IS_EARLY David Hildenbrand (Arm)
2026-09-22  6:49   ` Seongjun Hong
2026-09-21 19:59 ` [PATCH v2 10/13] mm/sparse: remove SECTION_MARKED_PRESENT David Hildenbrand (Arm)
2026-09-27 19:20   ` David Carlier
2026-09-28  7:28     ` David Hildenbrand (Arm)
2026-09-28  8:01       ` Dave Young
2026-09-28  8:50         ` David Hildenbrand (Arm)
2026-09-28  8:31       ` Baoquan He
2026-09-21 19:59 ` [PATCH v2 11/13] mm/sparse: remove flags parameter from sparse_init_one_section() David Hildenbrand (Arm)
2026-09-21 19:59 ` [PATCH v2 12/13] fs/proc/page: clarify comment in get_max_dump_pfn() David Hildenbrand (Arm)
2026-09-21 19:59 ` [PATCH v2 13/13] mm/memory_hotplug: drop CONFIG_HAVE_ARCH_PFN_VALID handling from pfn_to_online_page() David Hildenbrand (Arm)
2026-09-22  4:25   ` Oscar Salvador (SUSE)
2026-09-21 22:53 ` [PATCH v2 00/13] mm/sparse: remove SECTION_MARKED_PRESENT and further cleanups Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DLLDI7J2Z7L3.142FJJM03D1IV@nvidia.com \
    --to=ziy@nvidia.com \
    --cc=akpm@linux-foundation.org \
    --cc=axelrasmussen@google.com \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=baoquan.he@linux.dev \
    --cc=brendan.jackman@linux.dev \
    --cc=dakr@kernel.org \
    --cc=david@kernel.org \
    --cc=driver-core@lists.linux.dev \
    --cc=gregkh@linuxfoundation.org \
    --cc=hannes@cmpxchg.org \
    --cc=jan.kiszka@siemens.com \
    --cc=kasong@tencent.com \
    --cc=kbingham@kernel.org \
    --cc=liam@infradead.org \
    --cc=linux-cxl@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=osalvador@suse.de \
    --cc=qi.zheng@linux.dev \
    --cc=rafael@kernel.org \
    --cc=rppt@kernel.org \
    --cc=shakeel.butt@linux.dev \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=weixugc@google.com \
    --cc=yuanchu@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®