mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Len Brown <lenb@kernel.org>
To: linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: Thomas Renninger <trenn@suse.de>, Andi Kleen <ak@linux.intel.com>,
	Len Brown <len.brown@intel.com>
Subject: [PATCH 25/85] Introduce FW_BUG, FW_WARN and FW_INFO to consistenly tell users about BIOS bugs
Date: Sat, 11 Oct 2008 02:35:45 -0400	[thread overview]
Message-ID: <a0ad05c75aa362c91f4d9cd91ff375a739574dd8.1223706853.git.len.brown@intel.com> (raw)
In-Reply-To: <1223707005-26864-1-git-send-email-lenb@kernel.org>
In-Reply-To: <1d80ebdb81444701024ad9b9f026516561496a43.1223706853.git.len.brown@intel.com>

From: Thomas Renninger <trenn@suse.de>

The idea is to add this to printk after the severity:
printk(KERN_ERR FW_BUG "This is not our fault, BIOS developer: fix it by
simply add ...\n");

If a Firmware issue should be hidden, because it is
work-arounded, but you still want to see something popping up e.g.
for info only:
printk(KERN_INFO FW_INFO "This is done stupid, we can handle it,
but it should better be avoided in future\n");

or on the Linuxfirmwarekit to tell vendors that they did something
stupid or wrong without bothering the user:
printk(KERN_INFO FW_BUG "This is done stupid, we can handle it,
but it should better be avoided in future\n");

Some use cases:
  - If a user sees a [Firmware Bug] message in the kernel
    he should first update the BIOS before wasting time with
    debugging and submiting on old firmware code to mailing
    lists.

  - The linuxfirmwarekit (http://www.linuxfirmwarekit.org)
    tries to detect firmware bugs. It currently is doing that
    in userspace which results in:
        - Huge test scripts that could be a one liner in the kernel
        - A lot of BIOS bugs are already absorbed by the kernel

What do we need such a stupid linuxfirmwarekit for?

  - Vendors: Can test their BIOSes for Linux compatibility.
    There will be the time when vendors realize that the test utils
    on Linux are more strict and using them increases the qualitity
    and stability of their products.

  - Vendors: Can easily fix up their BIOSes and be more Linux
    compatible by:
    dmesg |grep "Firmware Bug"
    and send the result to their BIOS developer colleagues who should
    know what the messages are about and how to fix them, without
    the need of studying kernel code.

  - Distributions: can do a first automated HW/BIOS checks.
    This can then be done without the need of asking kernel developers
    who need to dig down the code and explain the details.
    Certification can/will just be rejected until
    dmesg |grep "Firmware Bug" is empty.

  - Thus this can be used as an instrument to enforce cleaner BIOS
    code. Currently every stupid Windows ACPI bug is
    re-implemented in Linux which is a rather unfortunate situation.
    We already have the power to avoid this in e.g. memory
    or cpu hot-plug ACPI implementations, because Linux certification
    is a must for most vendors in the server area.
    Working towards being able to do that in the laptop area
    (vendors are starting to look at Linux here also and will use this tool)
    is the goal. At least provide them a tool to make it as easy
    for this guys (e.g. not needing to browse kernel code) as possible.

  - The ordinary Linux user: can go into the next shop, boots the
    firmwarekit on his most preferred machines. He chooses one without
    BIOS bugs. Unsupported HW is ok, he likes to try out latest projects
    which might support them or likes to dig on it on his own, but he
    hates to workaround broken BIOSes like hell.

I double checked with the firmwarekit.
There they have:
So the mapping generally is (also depending on how likely the BIOS is
to blame, this could sometimes be difficult):
FW_INFO  = INFO
FW_WARN  = WARN
FW_BUG   = FAIL

For more info about the linuxfirmwarekit and why this is needed
can be found here:
http://www.linuxfirmwarekit.org

While severity matches with the firmwarekit, it might be tricky
to hide messages from the user.
E.g. we recently found out that on HP BIOSes negative temperatures
are returned, which seem to indicate that the thermal zone is
invalid.
We can work around that gracefully by ignoring the thermal zone
and we do not want to bother the ordinary user with a frightening
message: Firmware Bug: thermal management absolutely broken
but want to hide it from the user.

But in the linuxfirmwarekit this should be shown as a real
show stopper (the temperatures could really be wrong,
broken thermal management is one of the worst things
that can happen and the BIOS guys of the machine must
implement this properly).

It is intended to do that (hide it from the user with
KERN_INFO msg, but still print it as a BIOS bug) by:
printk(KERN_INFO FW_BUG "Negativ temperature values detected.
Try to workarounded, BIOS must get fixed\n");
Hope that works out..., no idea how to better hide it
as printk is the only way to easily provide this functionality.

Signed-off-by: Thomas Renninger <trenn@suse.de>
Signed-off-by: Andi Kleen <ak@linux.intel.com>
Signed-off-by: Len Brown <len.brown@intel.com>
---
 include/linux/kernel.h |   24 ++++++++++++++++++++++++
 1 files changed, 24 insertions(+), 0 deletions(-)

diff --git a/include/linux/kernel.h b/include/linux/kernel.h
index 2651f80..0b19848 100644
--- a/include/linux/kernel.h
+++ b/include/linux/kernel.h
@@ -190,6 +190,30 @@ extern int kernel_text_address(unsigned long addr);
 struct pid;
 extern struct pid *session_of_pgrp(struct pid *pgrp);
 
+/*
+ * FW_BUG
+ * Add this to a message where you are sure the firmware is buggy or behaves
+ * really stupid or out of spec. Be aware that the responsible BIOS developer
+ * should be able to fix this issue or at least get a concrete idea of the
+ * problem by reading your message without the need of looking at the kernel
+ * code.
+ * 
+ * Use it for definite and high priority BIOS bugs.
+ *
+ * FW_WARN
+ * Use it for not that clear (e.g. could the kernel messed up things already?)
+ * and medium priority BIOS bugs.
+ *
+ * FW_INFO
+ * Use this one if you want to tell the user or vendor about something
+ * suspicious, but generally harmless related to the firmware.
+ *
+ * Use it for information or very low priority BIOS bugs.
+ */
+#define FW_BUG		"[Firmware Bug]: "
+#define FW_WARN		"[Firmware Warn]: "
+#define FW_INFO		"[Firmware Info]: "
+
 #ifdef CONFIG_PRINTK
 asmlinkage int vprintk(const char *fmt, va_list args)
 	__attribute__ ((format (printf, 1, 0)));
-- 
1.5.5.1


  parent reply	other threads:[~2008-10-11  6:54 UTC|newest]

Thread overview: 111+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-11  6:35 ACPI patch queue for 2.6.28 Len Brown
2008-10-11  6:35 ` [PATCH 01/85] ACPI: Add missing acpi.debug_layer Documentation hunk from Thomas Renninger Len Brown
2008-10-11  6:35   ` [PATCH 02/85] acpi: replace AE_BAD_ADDRESS exception code with AE_ERROR Len Brown
2008-10-11  6:35   ` [PATCH 03/85] ACPI: Get the device power state in the course of scanning device Len Brown
2008-10-11  6:35   ` [PATCH 04/85] ACPI: Attach the ACPI device to the ACPI handle as early as possible Len Brown
2008-10-11  6:35   ` [PATCH 05/85] ACPI: Add "acpi.power_nocheck=1" to disable power state check in power transition Len Brown
2008-10-11  6:35   ` [PATCH 06/85] ACPI: Add DMI check " Len Brown
2008-10-11  6:35   ` [PATCH 07/85] ACPI : Load device driver according to the status of acpi device Len Brown
2008-10-11  6:35   ` [PATCH 08/85] ACPICA: Copy dynamically loaded tables to local buffer Len Brown
2008-10-11  6:35   ` [PATCH 09/85] ACPICA: Add check for invalid handle in acpi_get_object_info Len Brown
2008-10-11  6:35   ` [PATCH 10/85] ACPICA: Allow same ACPI table to be loaded/unloaded more than once Len Brown
2008-10-11  6:35   ` [PATCH 11/85] ACPICA: Fix wrong resource descriptor length for 64-bit build Len Brown
2008-10-11  6:35   ` [PATCH 12/85] ACPICA: Fix table compare code, length then data Len Brown
2008-10-11  6:35   ` [PATCH 13/85] ACPICA: Return status from global init function Len Brown
2008-10-11  6:35   ` [PATCH 14/85] ACPICA: Add function to dereference returned reference objects Len Brown
2008-10-11  6:35   ` [PATCH 15/85] ACPICA: Fix warning for 64-bit build Len Brown
2008-10-11  6:35   ` [PATCH 16/85] ACPICA: Cleanup macro definition file Len Brown
2008-10-11  6:35   ` [PATCH 17/85] ACPICA: Return method arg count from acpi_get_object_info Len Brown
2008-10-11  6:35   ` [PATCH 18/85] ACPICA: Update version to 20080701 Len Brown
2008-10-11  6:35   ` [PATCH 19/85] ACPICA: Add function to decode reference obj types to strings Len Brown
2008-10-11  6:35   ` [PATCH 20/85] ACPICA: Improve object conversion error messages Len Brown
2008-10-11  6:35   ` [PATCH 21/85] ACPICA: x2APIC support: changes for MADT and SRAT ACPI tables Len Brown
2008-10-11  6:35   ` [PATCH 22/85] ACPICA: Update version to 20080729 Len Brown
2008-10-11  6:35   ` [PATCH 23/85] ACPI: Clear WAK_STS on resume Len Brown
2008-10-13  9:01     ` Christian Borntraeger
2008-10-11  6:35   ` [PATCH 24/85] ACPI : Add the support for _TTS object Len Brown
2008-10-11  6:35   ` Len Brown [this message]
2008-10-11  6:35   ` [PATCH 26/85] ACPI: cpufreq, processor: Detect old BIOS, not supporting CPU freq on a recent CPU Len Brown
2008-10-11  6:35   ` [PATCH 27/85] CPUFREQ: powernow-k8: Try to detect old BIOS, not supporting CPU freq on a recent AMD CPUs Len Brown
2008-10-11  6:35   ` [PATCH 28/85] ACPI: dock: avoid check _STA method Len Brown
2008-10-11  6:35   ` [PATCH 29/85] dock: fix eject request process (2.6.27-rc1 regression) Len Brown
2008-10-11  6:35   ` [PATCH 30/85] dock: add _LCK support Len Brown
2008-10-11  6:35   ` [PATCH 31/85] dock: add bay and battery hotplug support Len Brown
2008-10-11  6:35   ` [PATCH 32/85] ACPI: introduce notifier change to avoid duplicates Len Brown
2008-10-11  6:35   ` [PATCH 33/85] ACPI: fix hotplug race Len Brown
2008-10-11  6:35   ` [PATCH 34/85] libata: remove functions now handed by ACPI dock driver Len Brown
2008-10-11  6:35   ` [PATCH 35/85] dock: introduce .uevent for devices in dock, eg libata Len Brown
2008-10-11  6:35   ` [PATCH 36/85] bay: remove driver, all functions now handled by dock driver Len Brown
2008-10-11  6:35   ` [PATCH 37/85] dock: fix for ATA bay in a dock station Len Brown
2008-10-11  6:35   ` [PATCH 38/85] dock: add 'type' sysfs file Len Brown
2008-10-11  6:35   ` [PATCH 39/85] dock: Shaohua Li is new maintainer Len Brown
2008-10-11  6:36   ` [PATCH 40/85] ACPI suspend: Always use the 32-bit waking vector Len Brown
2008-10-11  6:36   ` [PATCH 41/85] panasonic-laptop: add Panasonic Let's Note laptop extras driver v0.94 Len Brown
2008-10-11  6:36   ` [PATCH 42/85] ACPI: EC: do transaction from interrupt context Len Brown
2008-10-11  6:36   ` [PATCH 43/85] ACPI: EC: Rename some variables Len Brown
2008-10-11  6:36   ` [PATCH 44/85] ACPICA: add preemption point after each opcode parse Len Brown
2008-10-11  6:36   ` [PATCH 45/85] ACPI Suspend: Enable ACPI during resume if SCI_EN is not set Len Brown
2008-10-11  6:36   ` [PATCH 46/85] ACPI: don't enable control method power button as wakeup device when Fixed Power button is used Len Brown
2008-10-11  6:36   ` [PATCH 47/85] acer-wmi: Add rfkill support for wireless and bluetooth Len Brown
2008-10-11  6:36   ` [PATCH 48/85] acer-wmi: Remove wireless and bluetooth sysfs entries Len Brown
2008-10-11  6:36   ` [PATCH 49/85] ACPI: WMI: Enable event methods when registering notifiers Len Brown
2008-10-11  6:36   ` [PATCH 50/85] ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit kernels Len Brown
2008-10-11  6:36   ` [PATCH 51/85] ACPI: fix FADT parsing Len Brown
2008-10-11  6:36   ` [PATCH 52/85] fujitsu-laptop: better handling of P8010 hotkey Len Brown
2008-10-11  6:36   ` [PATCH 53/85] i7300_idle driver v1.55 Len Brown
2008-10-11  8:33     ` Ingo Molnar
2008-10-15 22:32       ` Len Brown
2008-10-16 22:05       ` [PATCH 1/2] x86: allow module driver to register idle notifier Len Brown
2008-10-21  1:57         ` Len Brown
2008-10-21 11:49           ` Ingo Molnar
2008-10-16 22:08       ` [PATCH 2/2] i7300_idle driver v1.55 Len Brown
2008-10-20 17:32         ` Randy Dunlap
2008-10-21 22:09           ` Pallipadi, Venkatesh
2008-10-21 22:15             ` Randy Dunlap
2008-10-21 23:02               ` Pallipadi, Venkatesh
2008-10-21 16:47         ` Andi Kleen
2008-10-21 22:34           ` Pallipadi, Venkatesh
2008-10-22  7:19             ` Andi Kleen
2008-10-22 23:34               ` [PATCH] Disable ioat channel only on platforms where ile driver can load Venki Pallipadi
2008-10-22 23:51                 ` [PATCH] Cleanup of i7300_idle based on review comments Venki Pallipadi
2008-10-24 17:03                   ` Len Brown
2008-10-24 17:02                 ` [PATCH] Disable ioat channel only on platforms where ile driver can load Len Brown
     [not found]                 ` <f12847240810270941v68a1cf7aqfa7db14fceb61fe5@mail.gmail.com>
2008-10-28 16:30                   ` Sosnowski, Maciej
2008-10-22 23:40               ` [PATCH 2/2] i7300_idle driver v1.55 Venki Pallipadi
2008-10-23  1:11                 ` Andi Kleen
2008-10-23  4:59                   ` Pallipadi, Venkatesh
2008-10-23 12:26                     ` Andi Kleen
2008-10-23 15:00                     ` Paul E. McKenney
2008-10-23 16:26                       ` Andi Kleen
2008-10-11  6:36   ` [PATCH 54/85] eeepc-laptop: Use standard interfaces Len Brown
2008-10-11  6:36   ` [PATCH 55/85] x86: remove magic number from ACPI sleep stack buffer Len Brown
2008-10-11  6:36   ` [PATCH 56/85] x86: trim " Len Brown
2008-10-11  6:36   ` [PATCH 57/85] ACPI: acpi_driver_data could only be applied to acpi_device Len Brown
2008-10-11  6:36   ` [PATCH 58/85] ACPI: toshiba_acpi.c fix sparse signedness mismatch warnings Len Brown
2008-10-11  6:36   ` [PATCH 59/85] ACPI: catch calls of acpi_driver_data on pointer of wrong type Len Brown
2008-10-11  6:36   ` [PATCH 60/85] toshiba_acpi: depends on INPUT Len Brown
2008-10-11  6:36   ` [PATCH 61/85] PNP: fix debug formatting (cosmetic) Len Brown
2008-10-11  6:36   ` [PATCH 62/85] PNPACPI: use dev_printk when possible Len Brown
2008-10-11  6:36   ` [PATCH 63/85] PNP: convert the last few pnp_info() uses to printk() Len Brown
2008-10-11  6:36   ` [PATCH 64/85] PNP: use new vsprintf symbolic function pointer format Len Brown
2008-10-11  6:36   ` [PATCH 65/85] PNP: remove some uses of DEBUG ifdef Len Brown
2008-10-11  6:36   ` [PATCH 66/85] PNP: add CONFIG_PNP_DEBUG_MESSAGES and pnp_dbg() Len Brown
2008-10-11  6:36   ` [PATCH 67/85] PNP: convert to using pnp_dbg() Len Brown
2008-10-11  6:36   ` [PATCH 68/85] PNP: remove old CONFIG_PNP_DEBUG option Len Brown
2008-10-11  6:36   ` [PATCH 69/85] ACPI: don't load acpi_cpufreq if acpi=off Len Brown
2008-10-11  6:36   ` [PATCH 70/85] ACPI: remove unused have_arch_parse_srat Len Brown
2008-10-11  6:36   ` [PATCH 71/85] acer-wmi: Remove private workqueue Len Brown
2008-10-11  6:36   ` [PATCH 72/85] Subject: ACPI dock: Use ACPI_EXCEPTION instead of printk(KERN_ERR Len Brown
2008-10-11  6:36   ` [PATCH 73/85] ACPI cm_sbs: Debug interface used for error message cleanup Len Brown
2008-10-11  6:36   ` [PATCH 74/85] ACPI memhotplug: " Len Brown
2008-10-11  6:36   ` [PATCH 75/85] ACPI processor: " Len Brown
2008-10-11  6:36   ` [PATCH 76/85] ACPI video: " Len Brown
2008-10-11  6:36   ` [PATCH 77/85] ACPI scan: " Len Brown
2008-10-11  6:36   ` [PATCH 78/85] ACPI fan: " Len Brown
2008-10-11  6:36   ` [PATCH 79/85] ACPI osl: " Len Brown
2008-10-11  6:36   ` [PATCH 80/85] ACPI thermal: " Len Brown
2008-10-11  6:36   ` [PATCH 81/85] ACPI system: " Len Brown
2008-10-11  6:36   ` [PATCH 82/85] ACPI: remove unused acpi_is_child_device() Len Brown
2008-10-11  6:36   ` [PATCH 83/85] ACPI: Enable EC device immediately after ACPI full initialization Len Brown
2008-10-11  6:36   ` [PATCH 84/85] delete drivers/acpi/bay.c Len Brown
2008-10-11  6:36   ` [PATCH 85/85] panasonic-laptop: fix build Len Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a0ad05c75aa362c91f4d9cd91ff375a739574dd8.1223706853.git.len.brown@intel.com \
    --to=lenb@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=len.brown@intel.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=trenn@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®