Hello Dmitry, On Fri, May 29, 2026 at 10:56:48PM -0700, Dmitry Torokhov wrote: > I like the ability to properly set up pointers for driver data, however > I do not think we should use named initializers for name field. As long > as we are not planning on moving its position I like the brevity of just > saying > > { "ili210x", .driver_data_ptr = &ili210x_chip }, > > Can we keep the old style for the name field? I have no strong opinion here, my patch introduces the named initializer for both members for consistency. Note that my patches for all the other subsystems (and also other *_device_id) do the same and you're the first maintainer with that expressed preference. I even sent a few patches that adapt initializers without .driver_data (e.g. https://lore.kernel.org/all/177932943265.3832404.360063047381979287.git-patchwork-notify@kernel.org/) that got positive feedback so far. So if you're ok with having input differ in style from (up to now) all other subsystems, I can rework the patch. Best regards Uwe