From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id BC604C4167B for ; Sat, 15 Jan 2022 13:09:09 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S231822AbiAONJE (ORCPT ); Sat, 15 Jan 2022 08:09:04 -0500 Received: from mxout01.lancloud.ru ([45.84.86.81]:33656 "EHLO mxout01.lancloud.ru" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S231700AbiAONJB (ORCPT ); Sat, 15 Jan 2022 08:09:01 -0500 Received: from LanCloud DKIM-Filter: OpenDKIM Filter v2.11.0 mxout01.lancloud.ru C5E4720E291F Received: from LanCloud Received: from LanCloud Received: from LanCloud Subject: Re: [PATCH] driver core: platform: Rename platform_get_irq_optional() to platform_get_irq_silent() To: =?UTF-8?Q?Uwe_Kleine-K=c3=b6nig?= CC: Mark Brown , Andrew Lunn , Ulf Hansson , Vignesh Raghavendra , KVM list , "Rafael J. Wysocki" , , Linus Walleij , "Amit Kucheria" , ALSA Development Mailing List , Jaroslav Kysela , "Guenter Roeck" , Thierry Reding , "MTD Maling List" , Linux I2C , "open list:GPIO SUBSYSTEM" , Miquel Raynal , , , linux-spi , Jiri Slaby , Khuong Dinh , Florian Fainelli , Matthias Schiffer , Kamal Dasu , Lee Jones , Bartosz Golaszewski , Daniel Lezcano , "Kishon Vijay Abraham I" , Geert Uytterhoeven , "open list:SERIAL DRIVERS" , bcm-kernel-feedback-list , Zhang Rui , , Linux PWM List , Robert Richter , "Saravanan Sekar" , Corey Minyard , Linux PM list , Liam Girdwood , "Mauro Carvalho Chehab" , John Garry , Takashi Iwai , Peter Korsgaard , "William Breathitt Gray" , Mark Gross , Hans de Goede , Alex Williamson , Borislav Petkov , Jakub Kicinski , Matthias Brugger , , Andy Shevchenko , Benson Leung , Pengutronix Kernel Team , Linux ARM , , "Tony Luck" , Richard Weinberger , Mun Yew Tham , Eric Auger , "Greg Kroah-Hartman" , Yoshihiro Shimoda , Cornelia Huck , "Linux MMC List" , Joakim Zhang , Linux Kernel Mailing List , Linux-Renesas , Vinod Koul , "James Morse" , Zha Qipeng , "Sebastian Reichel" , =?UTF-8?Q?Niklas_S=c3=b6derlund?= , , "Brian Norris" , "David S. Miller" References: <20220112085009.dbasceh3obfok5dc@pengutronix.de> <20220112213121.5ruae5mxwj6t3qiy@pengutronix.de> <20220113110831.wvwbm75hbfysbn2d@pengutronix.de> <20220113194358.xnnbhsoyetihterb@pengutronix.de> <386a7f56-38c8-229c-4fec-4b38a77c4121@omp.ru> <20220114202939.5kq5ud5opfosjlyc@pengutronix.de> From: Sergey Shtylyov Organization: Open Mobile Platform Message-ID: Date: Sat, 15 Jan 2022 16:08:52 +0300 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.10.1 MIME-Version: 1.0 In-Reply-To: <20220114202939.5kq5ud5opfosjlyc@pengutronix.de> Content-Type: text/plain; charset="windows-1252" Content-Language: en-US Content-Transfer-Encoding: 8bit X-Originating-IP: [192.168.11.198] X-ClientProxiedBy: LFEXT01.lancloud.ru (fd00:f066::141) To LFEX1907.lancloud.ru (fd00:f066::207) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 1/14/22 11:29 PM, Uwe Kleine-König wrote: >>> The subsystems regulator, clk and gpio have the concept of a dummy >>> resource. For regulator, clk and gpio there is a semantic difference >>> between the regular _get() function and the _get_optional() variant. >>> (One might return the dummy resource, the other won't. Unfortunately >>> which one implements which isn't the same for these three.) The >>> difference between platform_get_irq() and platform_get_irq_optional() is >>> only that the former might emit an error message and the later won't. >>> >>> To prevent people's expectations that there is a semantic difference >>> between these too, rename platform_get_irq_optional() to >>> platform_get_irq_silent() to make the actual difference more obvious. >>> >>> The #define for the old name can and should be removed once all patches >>> currently in flux still relying on platform_get_irq_optional() are >>> fixed. >> >> Hm... I'm afraid that with this #define they would never get fixed... :-) > > I will care for it. Ah! OK then. :-) >>> Signed-off-by: Uwe Kleine-König >>> --- >>> Hello, >>> >>> On Thu, Jan 13, 2022 at 02:45:30PM +0000, Mark Brown wrote: >>>> On Thu, Jan 13, 2022 at 12:08:31PM +0100, Uwe Kleine-König wrote: >>>> >>>>> This is all very unfortunate. In my eyes b) is the most sensible >>>>> sense, but the past showed that we don't agree here. (The most annoying >>>>> part of regulator_get is the warning that is emitted that regularily >>>>> makes customers ask what happens here and if this is fixable.) >>>> >>>> Fortunately it can be fixed, and it's safer to clearly specify things. >>>> The prints are there because when the description is wrong enough to >>>> cause things to blow up we can fail to boot or run messily and >>>> forgetting to describe some supplies (or typoing so they haven't done >>>> that) and people were having a hard time figuring out what might've >>>> happened. >>> >>> Yes, that's right. I sent a patch for such a warning in 2019 and pinged >>> occationally. Still waiting for it to be merged :-\ >>> (https://lore.kernel.org/r/20190625100412.11815-1-u.kleine-koenig@pengutronix.de) >>> >>>>> I think at least c) is easy to resolve because >>>>> platform_get_irq_optional() isn't that old yet and mechanically >>>>> replacing it by platform_get_irq_silent() should be easy and safe. >>>>> And this is orthogonal to the discussion if -ENOXIO is a sensible return >>>>> value and if it's as easy as it could be to work with errors on irq >>>>> lookups. >>>> >>>> It'd certainly be good to name anything that doesn't correspond to one >>>> of the existing semantics for the API (!) something different rather >>>> than adding yet another potentially overloaded meaning. >>> >>> It seems we're (at least) three who agree about this. Here is a patch >>> fixing the name. >> >> I can't say I genrally agree with this patch... > > Yes, I didn't count you to the three people signaling agreement. :-D >> [...] >>> diff --git a/include/linux/platform_device.h b/include/linux/platform_device.h >>> index 7c96f169d274..6d495f15f717 100644 >>> --- a/include/linux/platform_device.h >>> +++ b/include/linux/platform_device.h >>> @@ -69,7 +69,14 @@ extern void __iomem * >>> devm_platform_ioremap_resource_byname(struct platform_device *pdev, >>> const char *name); >>> extern int platform_get_irq(struct platform_device *, unsigned int); >>> -extern int platform_get_irq_optional(struct platform_device *, unsigned int); >>> +extern int platform_get_irq_silent(struct platform_device *, unsigned int); >>> + >>> +/* >>> + * platform_get_irq_optional was recently renamed to platform_get_irq_silent. >>> + * Fixup users to not break patches that were created before the rename. >>> + */ >>> +#define platform_get_irq_optional(pdev, index) platform_get_irq_silent(pdev, index) >>> + >> >> Yeah, why bother fixing if it compiles anyway? > > The plan is to remove the define in one or two kernel releases. The idea > is only to not break patches that are currently in next. > >> I think an inline wrapper with an indication to gcc that the function is deprecated >> (I just forgot how it should look) would be better instead... > > The deprecated function annotation is generally frowned upon. See > 771c035372a0. Not sure I share the sentiment but good to know about that. > Best regards > Uwe MBR, Sergey